{
    "dataType": "CVE_RECORD",
    "dataVersion": "5.2",
    "cveMetadata": {
        "cveId": "CVE-2026-82806",
        "assignerOrgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09",
        "state": "PUBLISHED",
        "assignerShortName": "apache",
        "dateReserved": "2026-08-31T04:34:45.853Z",
        "datePublished": "2026-10-01T10:58:32.654Z",
        "dateUpdated": "2026-10-01T14:57:12.282Z"
    },
    "containers": {
        "cna": {
            "providerMetadata": {
                "orgId": "f0158376-9dc2-43b6-827c-5f631a4d8d09",
                "shortName": "apache",
                "dateUpdated": "2026-10-01T10:58:32.654Z"
            },
            "title": "Apache APISIX: cross-request permission pollution via static permission list mutation",
            "problemTypes": [
                {
                    "descriptions": [
                        {
                            "description": "CWE-488 Exposure of data element to wrong session",
                            "lang": "en",
                            "cweId": "CWE-488",
                            "type": "CWE"
                        }
                    ]
                }
            ],
            "source": {
                "discovery": "UNKNOWN"
            },
            "affected": [
                {
                    "vendor": "Apache Software Foundation",
                    "product": "Apache APISIX",
                    "versions": [
                        {
                            "status": "affected",
                            "version": "2.3.0",
                            "lessThan": "3.7.0",
                            "versionType": "semver"
                        }
                    ],
                    "defaultStatus": "unaffected"
                }
            ],
            "descriptions": [
                {
                    "value": "Exposure of data element to wrong session vulnerability in Apache APISIX.\n\n\n\nThis issue affects Apache APISIX: from 2.3.0 before 3.7.0.\n\n\n\nUnder a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.\n\n\n\nUsers are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.",
                    "lang": "en",
                    "supportingMedia": [
                        {
                            "type": "text/html",
                            "base64": false,
                            "value": "<p>Exposure of data element to wrong session vulnerability in Apache APISIX.</p><p>This issue affects Apache APISIX: from 2.3.0 before 3.7.0.</p><p>Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.</p><p>Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.</p>"
                        }
                    ]
                }
            ],
            "references": [
                {
                    "url": "https://lists.apache.org/thread.html/wvkv2b4oy2fh9v79d30gtsy0bhqmzcdd",
                    "tags": [
                        "vendor-advisory"
                    ]
                }
            ],
            "metrics": [
                {
                    "scenarios": [
                        {
                            "lang": "en",
                            "value": "GENERAL"
                        }
                    ],
                    "format": "CVSS",
                    "cvssV4_0": {
                        "attackVector": "NETWORK",
                        "attackComplexity": "LOW",
                        "attackRequirements": "NONE",
                        "privilegesRequired": "LOW",
                        "userInteraction": "NONE",
                        "vulnConfidentialityImpact": "NONE",
                        "subConfidentialityImpact": "LOW",
                        "vulnIntegrityImpact": "NONE",
                        "subIntegrityImpact": "LOW",
                        "vulnAvailabilityImpact": "NONE",
                        "subAvailabilityImpact": "NONE",
                        "exploitMaturity": "NOT_DEFINED",
                        "Safety": "NOT_DEFINED",
                        "Automatable": "NOT_DEFINED",
                        "Recovery": "NOT_DEFINED",
                        "valueDensity": "NOT_DEFINED",
                        "vulnerabilityResponseEffort": "NOT_DEFINED",
                        "providerUrgency": "NOT_DEFINED",
                        "version": "4.0",
                        "baseSeverity": "MEDIUM",
                        "baseScore": 5.3,
                        "vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
                    }
                }
            ],
            "credits": [
                {
                    "lang": "en",
                    "value": "Lok",
                    "type": "reporter"
                }
            ],
            "x_generator": {
                "engine": "Vulnogram 1.0.3"
            }
        },
        "adp": [
            {
                "title": "CVE Program Container",
                "references": [
                    {
                        "url": "http://www.openwall.com/lists/oss-security/2026/10/01/3"
                    }
                ],
                "providerMetadata": {
                    "orgId": "af854a3a-2127-422b-91ae-364da2661108",
                    "shortName": "CVE",
                    "dateUpdated": "2026-10-01T13:10:57.814Z"
                }
            },
            {
                "metrics": [
                    {
                        "other": {
                            "type": "ssvc",
                            "content": {
                                "timestamp": "2026-10-01T14:57:00.655996Z",
                                "id": "CVE-2026-82806",
                                "options": [
                                    {
                                        "Exploitation": "none"
                                    },
                                    {
                                        "Automatable": "no"
                                    },
                                    {
                                        "Technical Impact": "partial"
                                    }
                                ],
                                "role": "CISA Coordinator",
                                "version": "2.0.3"
                            }
                        }
                    }
                ],
                "title": "CISA ADP Vulnrichment",
                "providerMetadata": {
                    "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
                    "shortName": "CISA-ADP",
                    "dateUpdated": "2026-10-01T14:57:12.282Z"
                }
            }
        ]
    }
}