{
    "dataType": "CVE_RECORD",
    "dataVersion": "5.2",
    "cveMetadata": {
        "cveId": "CVE-2026-48717",
        "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
        "state": "PUBLISHED",
        "assignerShortName": "GitHub_M",
        "dateReserved": "2026-05-22T18:47:27.755Z",
        "datePublished": "2026-09-15T09:57:53.707Z",
        "dateUpdated": "2026-09-15T13:52:56.107Z"
    },
    "containers": {
        "cna": {
            "title": "OpenAM OAuth Authorization Bypass via PKCE Challenge",
            "problemTypes": [
                {
                    "descriptions": [
                        {
                            "cweId": "CWE-285",
                            "lang": "en",
                            "description": "CWE-285: Improper Authorization",
                            "type": "CWE"
                        }
                    ]
                }
            ],
            "metrics": [
                {
                    "cvssV4_0": {
                        "attackVector": "NETWORK",
                        "attackComplexity": "HIGH",
                        "attackRequirements": "PRESENT",
                        "privilegesRequired": "NONE",
                        "userInteraction": "NONE",
                        "vulnConfidentialityImpact": "HIGH",
                        "vulnIntegrityImpact": "HIGH",
                        "vulnAvailabilityImpact": "NONE",
                        "subConfidentialityImpact": "NONE",
                        "subIntegrityImpact": "NONE",
                        "subAvailabilityImpact": "NONE",
                        "baseScore": 9.1,
                        "baseSeverity": "CRITICAL",
                        "vectorString": "CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N",
                        "version": "4.0"
                    }
                }
            ],
            "references": [
                {
                    "name": "https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-4v2w-2wqp-mc85",
                    "tags": [
                        "x_refsource_CONFIRM"
                    ],
                    "url": "https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-4v2w-2wqp-mc85"
                },
                {
                    "name": "https://github.com/OpenIdentityPlatform/OpenAM/commit/97a34d9fee17395e8e052bfc45eb5855f436153e",
                    "tags": [
                        "x_refsource_MISC"
                    ],
                    "url": "https://github.com/OpenIdentityPlatform/OpenAM/commit/97a34d9fee17395e8e052bfc45eb5855f436153e"
                },
                {
                    "name": "https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1",
                    "tags": [
                        "x_refsource_MISC"
                    ],
                    "url": "https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1"
                }
            ],
            "affected": [
                {
                    "vendor": "OpenIdentityPlatform",
                    "product": "OpenAM",
                    "versions": [
                        {
                            "version": "< 16.1.1",
                            "status": "affected"
                        }
                    ]
                }
            ],
            "providerMetadata": {
                "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
                "shortName": "GitHub_M",
                "dateUpdated": "2026-09-15T09:57:53.707Z"
            },
            "descriptions": [
                {
                    "lang": "en",
                    "value": "Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1."
                }
            ],
            "source": {
                "advisory": "GHSA-4v2w-2wqp-mc85",
                "discovery": "UNKNOWN"
            }
        },
        "adp": [
            {
                "metrics": [
                    {
                        "other": {
                            "type": "ssvc",
                            "content": {
                                "timestamp": "2026-09-15T13:25:12.374530Z",
                                "id": "CVE-2026-48717",
                                "options": [
                                    {
                                        "Exploitation": "none"
                                    },
                                    {
                                        "Automatable": "no"
                                    },
                                    {
                                        "Technical Impact": "partial"
                                    }
                                ],
                                "role": "CISA Coordinator",
                                "version": "2.0.3"
                            }
                        }
                    }
                ],
                "title": "CISA ADP Vulnrichment",
                "providerMetadata": {
                    "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
                    "shortName": "CISA-ADP",
                    "dateUpdated": "2026-09-15T13:52:56.107Z"
                }
            }
        ]
    }
}