01 Record
CVE-2026-15810
Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover
HighPUBLISHEDCNA: GoogleCloud
CNA base score8.7 CVSS v4.0CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber
02 Description
Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover
03 Exploitation and scoring
- Exploitation
- Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
- SSVC decision
- ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
- AutomatablenoAt least one step from reconnaissance to exploitation cannot be reliably automated.
- Technical ImpacttotalSuccessful exploitation gives total control of the vulnerable component.
- EPSS probability
- 0.45% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 39.0% of scored records. A rank, not a probability.
- NVD base score
- 8.7 (CVSS v4.0), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Amber
- NVD analysis status
- Awaiting Analysis. NVD last modified this record on 2026-10-24.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2026-07-24 11:04Z3 MO AGO
- Last updated
- 2026-07-24 12:35Z3 MO AGO
- Reserved
- 2026-07-15
- Assigning CNA
- GoogleCloud
- Record state
- PUBLISHED
- Severity
- High (CVSS 8.7)
- CNA CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.2
- Document digest
- 43d76c7fb1671b0e517e8991a422188e4d0b74264b9b3fa8a989fbcdb4eb20fd
05 Affected products
VendorProductVersionsPlatforms
Google CloudLooker0 to < 25.6.103, 0 to < 25.12.65, 0 to < 25.18.68, 0 to < 26.0.66, 0 to < 26.2.47, 0 to < 26.4.36, 0 to < 26.6.28, 0 to < 26.8.7Looker-hosted, Self-hosted
06 References
- docs.cloud.google.comhttps://docs.cloud.google.com/support/bulletins#gcp-2026-049
- docs.cloud.google.comhttps://docs.cloud.google.com/looker/docs/release-notes#July_22_2026
07 Remediation
This vulnerability has been mitigated for Looker-hosted instances, and no user action is required. For Self-hosted Looker instances, customers should upgrade to one of the patched versions or later: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.