{
    "dataType": "CVE_RECORD",
    "dataVersion": "5.2",
    "cveMetadata": {
        "cveId": "CVE-2026-120843",
        "assignerOrgId": "21595511-bba5-4825-b968-b78d1f9984a3",
        "state": "PUBLISHED",
        "assignerShortName": "Patchstack",
        "dateReserved": "2026-11-03T00:24:21.836Z",
        "datePublished": "2026-11-03T16:51:22.083Z",
        "dateUpdated": "2026-11-03T16:52:22.878Z"
    },
    "containers": {
        "cna": {
            "providerMetadata": {
                "orgId": "21595511-bba5-4825-b968-b78d1f9984a3",
                "shortName": "Patchstack",
                "dateUpdated": "2026-11-03T16:52:22.878Z"
            },
            "title": "WordPress Posts Table with Search & Sort plugin <= 1.4.14 - Cross Site Scripting (XSS) vulnerability",
            "datePublic": "2026-11-03T16:50:00.000Z",
            "descriptions": [
                {
                    "lang": "en",
                    "value": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Barn2 Plugins Posts Table with Search & Sort posts-data-table allows Stored XSS.This issue affects Posts Table with Search & Sort: from n/a through 1.4.14.",
                    "supportingMedia": [
                        {
                            "type": "text/html",
                            "base64": false,
                            "value": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Barn2 Plugins Posts Table with Search & Sort posts-data-table allows Stored XSS.<p>This issue affects Posts Table with Search & Sort: from n/a through 1.4.14.</p>"
                        }
                    ]
                }
            ],
            "affected": [
                {
                    "vendor": "Barn2 Plugins",
                    "product": "Posts Table with Search & Sort",
                    "packageName": "posts-data-table",
                    "collectionURL": "https://wordpress.org/plugins",
                    "defaultStatus": "unaffected",
                    "versions": [
                        {
                            "version": "0",
                            "versionType": "custom",
                            "status": "affected",
                            "lessThanOrEqual": "1.4.14",
                            "changes": [
                                {
                                    "at": "1.4.15",
                                    "status": "unaffected"
                                }
                            ]
                        }
                    ]
                }
            ],
            "references": [
                {
                    "url": "https://patchstack.com/database/wordpress/plugin/posts-data-table/vulnerability/wordpress-posts-table-with-search-sort-plugin-1-4-14-cross-site-scripting-xss-vulnerability?_s_id=cve",
                    "tags": [
                        "vdb-entry"
                    ]
                }
            ],
            "credits": [
                {
                    "lang": "en",
                    "value": "johska | Patchstack Bug Bounty Program",
                    "type": "finder"
                }
            ],
            "metrics": [
                {
                    "format": "CVSS",
                    "scenarios": [
                        {
                            "lang": "en",
                            "value": "GENERAL"
                        }
                    ],
                    "cvssV3_1": {
                        "version": "3.1",
                        "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L",
                        "baseScore": 6.5,
                        "baseSeverity": "MEDIUM",
                        "attackVector": "NETWORK",
                        "attackComplexity": "LOW",
                        "privilegesRequired": "LOW",
                        "userInteraction": "REQUIRED",
                        "scope": "CHANGED",
                        "confidentialityImpact": "LOW",
                        "integrityImpact": "LOW",
                        "availabilityImpact": "LOW"
                    }
                }
            ],
            "problemTypes": [
                {
                    "descriptions": [
                        {
                            "cweId": "CWE-79",
                            "description": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')",
                            "lang": "en",
                            "type": "CWE"
                        }
                    ]
                }
            ],
            "impacts": [
                {
                    "capecId": "CAPEC-592",
                    "descriptions": [
                        {
                            "lang": "en",
                            "value": "Stored XSS"
                        }
                    ]
                }
            ],
            "solutions": [
                {
                    "lang": "en",
                    "value": "Update the WordPress Posts Table with Search & Sort plugin to the latest available version (at least 1.4.15).",
                    "supportingMedia": [
                        {
                            "type": "text/html",
                            "base64": false,
                            "value": "Update the WordPress Posts Table with Search & Sort plugin to the latest available version (at least 1.4.15)."
                        }
                    ]
                }
            ],
            "tags": [
                "x_open-source"
            ]
        }
    }
}