{
    "dataType": "CVE_RECORD",
    "dataVersion": "5.2",
    "cveMetadata": {
        "cveId": "CVE-2026-107809",
        "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
        "state": "PUBLISHED",
        "assignerShortName": "GitHub_M",
        "dateReserved": "2026-10-08T21:23:59.821Z",
        "datePublished": "2026-10-09T15:22:10.562Z",
        "dateUpdated": "2026-10-09T16:45:22.243Z"
    },
    "containers": {
        "cna": {
            "title": "Nginx-UI AuthRequired token cookie fallback enables CSRF against management APIs",
            "problemTypes": [
                {
                    "descriptions": [
                        {
                            "cweId": "CWE-352",
                            "lang": "en",
                            "description": "CWE-352: Cross-Site Request Forgery (CSRF)",
                            "type": "CWE"
                        }
                    ]
                }
            ],
            "metrics": [
                {
                    "cvssV3_1": {
                        "attackComplexity": "LOW",
                        "attackVector": "NETWORK",
                        "availabilityImpact": "HIGH",
                        "baseScore": 8.8,
                        "baseSeverity": "HIGH",
                        "confidentialityImpact": "HIGH",
                        "integrityImpact": "HIGH",
                        "privilegesRequired": "NONE",
                        "scope": "UNCHANGED",
                        "userInteraction": "REQUIRED",
                        "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H",
                        "version": "3.1"
                    }
                }
            ],
            "references": [
                {
                    "name": "https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-33rr-wq23-g6gg",
                    "tags": [
                        "x_refsource_CONFIRM"
                    ],
                    "url": "https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-33rr-wq23-g6gg"
                },
                {
                    "name": "https://github.com/0xJacky/nginx-ui/commit/a3999bd78a3b97ab22e6b5e9fd478ac57598a954",
                    "tags": [
                        "x_refsource_MISC"
                    ],
                    "url": "https://github.com/0xJacky/nginx-ui/commit/a3999bd78a3b97ab22e6b5e9fd478ac57598a954"
                },
                {
                    "name": "https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0",
                    "tags": [
                        "x_refsource_MISC"
                    ],
                    "url": "https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0"
                }
            ],
            "affected": [
                {
                    "vendor": "0xJacky",
                    "product": "nginx-ui",
                    "versions": [
                        {
                            "version": ">= 2.0.0, < 2.5.0",
                            "status": "affected"
                        }
                    ]
                }
            ],
            "providerMetadata": {
                "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
                "shortName": "GitHub_M",
                "dateUpdated": "2026-10-09T15:22:10.562Z"
            },
            "descriptions": [
                {
                    "lang": "en",
                    "value": "Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, AuthRequired accepts a browser-managed token cookie as an API credential after the front end stores the JWT in that cookie. Because management endpoints do not universally require a CSRF token or perform Origin or Referer validation, a remote attacker can induce a logged-in administrator's browser to submit authenticated cross-site state-changing requests, including POST /api/configs. The attack requires an administrator account without OTP/Passkey or a target endpoint that does not require secure-session proof. The attacker cannot read the cross-origin response but can modify Nginx configuration, trigger reloads, or invoke other management operations reachable with the victim's session. This issue is fixed in version 2.5.0."
                }
            ],
            "source": {
                "advisory": "GHSA-33rr-wq23-g6gg",
                "discovery": "UNKNOWN"
            }
        },
        "adp": [
            {
                "metrics": [
                    {
                        "other": {
                            "type": "ssvc",
                            "content": {
                                "timestamp": "2026-10-09T16:16:13.986272Z",
                                "id": "CVE-2026-107809",
                                "options": [
                                    {
                                        "Exploitation": "none"
                                    },
                                    {
                                        "Automatable": "no"
                                    },
                                    {
                                        "Technical Impact": "total"
                                    }
                                ],
                                "role": "CISA Coordinator",
                                "version": "2.0.3"
                            }
                        }
                    }
                ],
                "title": "CISA ADP Vulnrichment",
                "providerMetadata": {
                    "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
                    "shortName": "CISA-ADP",
                    "dateUpdated": "2026-10-09T16:45:22.243Z"
                }
            }
        ]
    }
}