{
    "dataType": "CVE_RECORD",
    "dataVersion": "5.2",
    "cveMetadata": {
        "cveId": "CVE-2026-100368",
        "assignerOrgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
        "state": "PUBLISHED",
        "assignerShortName": "GitHub_M",
        "dateReserved": "2026-09-25T19:19:54.698Z",
        "datePublished": "2026-09-25T19:53:56.299Z",
        "dateUpdated": "2026-09-30T00:06:47.101Z"
    },
    "containers": {
        "cna": {
            "title": "CliInvoke.Specializations: Command injection in PowerShell and Cmd shell wrappers",
            "problemTypes": [
                {
                    "descriptions": [
                        {
                            "cweId": "CWE-78",
                            "lang": "en",
                            "description": "CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')",
                            "type": "CWE"
                        }
                    ]
                }
            ],
            "metrics": [
                {
                    "cvssV3_1": {
                        "attackComplexity": "LOW",
                        "attackVector": "LOCAL",
                        "availabilityImpact": "HIGH",
                        "baseScore": 8.4,
                        "baseSeverity": "HIGH",
                        "confidentialityImpact": "HIGH",
                        "integrityImpact": "HIGH",
                        "privilegesRequired": "NONE",
                        "scope": "UNCHANGED",
                        "userInteraction": "NONE",
                        "vectorString": "CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H",
                        "version": "3.1"
                    }
                }
            ],
            "references": [
                {
                    "name": "https://github.com/alastairlundy/CliInvoke/security/advisories/GHSA-wrvw-254r-wpmv",
                    "tags": [
                        "x_refsource_CONFIRM"
                    ],
                    "url": "https://github.com/alastairlundy/CliInvoke/security/advisories/GHSA-wrvw-254r-wpmv"
                }
            ],
            "affected": [
                {
                    "vendor": "alastairlundy",
                    "product": "CliInvoke.Specializations",
                    "versions": [
                        {
                            "version": ">= 2.2.0, <= 2.8.4",
                            "status": "affected"
                        },
                        {
                            "version": ">= 2.9.0, <= 2.9.3",
                            "status": "affected"
                        },
                        {
                            "version": ">= 2.10.0, <= 2.10.4",
                            "status": "affected"
                        },
                        {
                            "version": ">= 3.0.0-alpha.1, <= 3.0.0-alpha.4",
                            "status": "affected"
                        },
                        {
                            "version": ">= 3.0.0-alpha.8, <= 3.0.0-alpha.10",
                            "status": "affected"
                        },
                        {
                            "version": ">= 1.0.0-rc.1, <= 1.6.1.1",
                            "status": "affected"
                        }
                    ]
                }
            ],
            "providerMetadata": {
                "orgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
                "shortName": "GitHub_M",
                "dateUpdated": "2026-09-25T19:53:56.299Z"
            },
            "descriptions": [
                {
                    "lang": "en",
                    "value": "CliInvoke is a .NET library for invoking command-line programs, and its `CliInvoke.Specializations` packages provide specialized wrappers for shells such as PowerShell and Windows Command Prompt. `CliInvoke.Specializations` versions 2.2.0 through 2.8.4, 2.9.0 through 2.9.3, 2.10.0 through 2.10.4, 3.0.0-alpha.1 through 3.0.0-alpha.4, and 3.0.0-alpha.8 through 3.0.0-alpha.10, as well as `AlastairLundy.CliInvoke.Specializations` versions 1.0.0-rc.1 through 1.6.1.1, contain an OS command injection vulnerability in their PowerShell and Cmd wrappers. The wrappers pass a caller-controlled target and arguments to `pwsh -Command` or `cmd /c` using a single `ProcessStartInfo.Arguments` string, allowing a double quote in untrusted input to break operating-system-level quoting and cause the shell to execute an additional command with the host process's privileges. The vulnerability is patched in `CliInvoke.Specializations` versions 2.8.5, 2.9.4, 2.10.5, and 3.0.0-beta.1, and in `AlastairLundy.CliInvoke.Specializations` version 2.0.2. No complete workaround is available; users unable to upgrade should reject or remove double quotes from target paths and arguments, additionally reject shell metacharacters in versions 2.2.0 through 2.9.2 and 3.0.0-alpha.1 through 3.0.0-alpha.4, or bypass the PowerShell and Cmd wrappers and invoke target processes directly when handling untrusted input."
                }
            ],
            "source": {
                "advisory": "GHSA-wrvw-254r-wpmv",
                "discovery": "UNKNOWN"
            }
        },
        "adp": [
            {
                "metrics": [
                    {
                        "other": {
                            "type": "ssvc",
                            "content": {
                                "timestamp": "2026-09-30T00:06:37.206021Z",
                                "id": "CVE-2026-100368",
                                "options": [
                                    {
                                        "Exploitation": "none"
                                    },
                                    {
                                        "Automatable": "no"
                                    },
                                    {
                                        "Technical Impact": "total"
                                    }
                                ],
                                "role": "CISA Coordinator",
                                "version": "2.0.3"
                            }
                        }
                    }
                ],
                "title": "CISA ADP Vulnrichment",
                "providerMetadata": {
                    "orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
                    "shortName": "CISA-ADP",
                    "dateUpdated": "2026-09-30T00:06:47.101Z"
                }
            }
        ]
    }
}