01 Record
CVE-2025-5982
Insufficient Granularity of Access Control in GitLab
LowPUBLISHEDCNA: GitLab
CNA base score3.7 CVSS v3.xCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
02 Description
Insufficient Granularity of Access Control in GitLab
03 Exploitation and scoring
- Exploitation
- Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
- SSVC decision
- ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
- AutomatableyesAn attacker can reliably automate reconnaissance through exploitation, so this scales.
- Technical ImpactpartialSuccessful exploitation gives limited control of the vulnerable component.
- EPSS probability
- 0.31% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 23.8% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- NVD analysis status
- Analyzed. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2025-06-12 16:27Z1 YR AGO
- Last updated
- 2025-06-12 17:29Z1 YR AGO
- Reserved
- 2025-06-10
- Assigning CNA
- GitLab
- Record state
- PUBLISHED
- Severity
- Low (CVSS 3.7)
- CNA CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-1220Insufficient Granularity of Access ControlBase
- Data version
- 5.1
- Document digest
- 0a28659e9b4798bc1d986fe4ad75cc0998de64c647558a2b3a855430a6ce0fc0
05 Affected products
VendorProductVersionsPlatforms
06 References
- gitlab.comGitLab Issue #514456https://gitlab.com/gitlab-org/gitlab/-/issues/514456
07 Remediation
Upgrade to versions 17.10.8, 17.11.4, 18.0.2 or above.