CVE-2025-0127
PAN-OS: Authenticated Admin Command Injection Vulnerability in PAN-OS VM-Series
02 Description
PAN-OS: Authenticated Admin Command Injection Vulnerability in PAN-OS VM-Series
03 Exploitation and scoring
- Exploitation
- Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
- SSVC decision
- ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
- AutomatablenoAt least one step from reconnaissance to exploitation cannot be reliably automated.
- Technical ImpacttotalSuccessful exploitation gives total control of the vulnerable component.
- EPSS probability
- 0.56% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 46.7% of scored records. A rank, not a probability.
- NVD base score
- 7.1 (CVSS v4.0), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:N/R:U/V:D/RE:M/U:Amber
- NVD analysis status
- Deferred. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2025-04-11 02:01Z1 YR AGO
- Last updated
- 2025-04-11 16:01Z1 YR AGO
- Reserved
- 2024-12-20
- Assigning CNA
- palo_alto
- Record state
- PUBLISHED
- Severity
- High (CVSS 7.1)
- CNA CVSS vector
- CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/AU:N/R:U/V:D/RE:M/U:Amber
- Weaknesses
- CWE-78Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')Base
- Data version
- 5.1
- Document digest
- f611c32596ac0842c9dabe87828421259ff593a5610b720feb518973bdaf3e84
05 Affected products
06 References
- security.paloaltonetworks.comhttps://security.paloaltonetworks.com/CVE-2025-0127
07 Remediation
VersionMinor VersionSuggested SolutionPAN-OS 11.2 on VM-Series No action needed PAN-OS 11.1 on VM-Series No action needed PAN-OS 11.0 on VM-Series 11.0.0 through 11.0.3 Upgrade to 11.0.4 or later PAN-OS 10.2 on VM-Series 10.2.0 through 10.2.8 Upgrade to 10.2.9 or later PAN-OS 10.1 on VM-Series 10.1.0 through 10.1.14 Upgrade to 10.1.14-h13 or later PAN-OS on non VM-Series platforms No action neededAll other older unsupported PAN-OS versions Upgrade to a supported fixed version PAN-OS 11.0 is EoL. We listed it in this section for completeness because we added a patch for PAN-OS 11.0 before it reached EoL. If you are running PAN-OS 11.0 in any of your firewalls, we strongly recommend that you upgrade from this EoL vulnerable version to a fixed version.