synced 13 MIN AGO
01 Record

CVE-2024-10977

PostgreSQL libpq retains an error message from man-in-the-middle

LowPUBLISHEDCNA: PostgreSQL
CNA base score3.1 CVSS v3.xCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N

02 Description

PostgreSQL libpq retains an error message from man-in-the-middle

03 Exploitation and scoring

Exploitation
Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
SSVC decision
  • ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
  • AutomatablenoAt least one step from reconnaissance to exploitation cannot be reliably automated.
  • Technical ImpactpartialSuccessful exploitation gives limited control of the vulnerable component.
CISA publishes the decision points, not a final SSVC decision. The decision also depends on mission and well-being impact, which is a property of your deployment rather than of the vulnerability.
EPSS probability
0.39% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 33.7% of scored records. A rank, not a probability.
NVD base score
3.7 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
Low. Red Hat's rating for its own products, not a CVSS rating.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2024-11-14 13:00Z1 YR AGO
Last updated
2025-11-03 21:51Z11 MO AGO
Reserved
2024-11-07
Assigning CNA
PostgreSQL
Record state
PUBLISHED
Severity
Low (CVSS 3.1)
CNA CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
Weaknesses
  • CWE-348Use of Less Trusted SourceBase
  • CWE-345Insufficient Verification of Data AuthenticityClass
Data version
5.2
Document digest
073ec9d7ddd13f777136971eae84fcbe056f8417896fee4b94a95b7c02623b27

05 Affected products

VendorProductVersionsPlatforms
n/aPostgreSQL17 to < 17.1, 16 to < 16.5, 15 to < 15.9, 14 to < 14.14, 13 to < 13.17, 0 to < 12.21—

06 References

07 Fixed in

Debian 12

  • postgresql-15
    Fixed in 15.9-0+deb12u1

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

Debian 13

  • postgresql-17
    Fixed in 17.1-1

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 20.04 LTS

  • postgresql-12
    Fixed in 12.22-0ubuntu0.20.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 22.04 LTS

  • postgresql-14
    Fixed in 14.15-0ubuntu0.22.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 24.04 LTS

  • postgresql-16
    Fixed in 16.6-0ubuntu0.24.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu Pro 14.04 LTS

  • postgresql-9.3
    No fix yet

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu Pro 16.04 LTS

  • postgresql-9.5
    Fixed in 9.5.25-0ubuntu0.16.04.1+esm10
    Available with Ubuntu Pro (Infra-only): https://ubuntu.com/pro

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu Pro 18.04 LTS

  • postgresql-10
    No fix yet

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.