01 Record
CVE-2023-51503
WordPress WooCommerce Payments Plugin <= 6.6.2 is vulnerable to Insecure Direct Object References (IDOR)
MediumPUBLISHEDCNA: Patchstack
CNA base score5.9 CVSS v3.xCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
02 Description
WordPress WooCommerce Payments Plugin <= 6.6.2 is vulnerable to Insecure Direct Object References (IDOR)
03 Exploitation and scoring
- Exploitation
- Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
- SSVC decision
- ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
- AutomatablenoAt least one step from reconnaissance to exploitation cannot be reliably automated.
- Technical ImpactpartialSuccessful exploitation gives limited control of the vulnerable component.
- EPSS probability
- 0.46% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 39.9% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2023-12-31 17:59Z2 YR AGO
- Last updated
- 2026-04-28 16:09Z6 MO AGO
- Reserved
- 2023-12-20
- Assigning CNA
- Patchstack
- Record state
- PUBLISHED
- Severity
- Medium (CVSS 5.9)
- CNA CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-639Authorization Bypass Through User-Controlled KeyBase
- Data version
- 5.2
- Document digest
- 1321a6cce822a9def91a558cb155fcdc1f2418657c58adf4bb80feb215528788
05 Affected products
VendorProductVersionsPlatforms
06 References
07 Remediation
Update to 6.7.0 or a higher version.