01 Record
CVE-2023-5009
Incorrect Authorization in GitLab
HighPUBLISHEDCNA: GitLab
CNA base score8.2 CVSS v3.xCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
02 Description
Incorrect Authorization in GitLab
03 Exploitation and scoring
- Exploitation
- Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
- SSVC decision
- ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
- AutomatablenoAt least one step from reconnaissance to exploitation cannot be reliably automated.
- Technical ImpacttotalSuccessful exploitation gives total control of the vulnerable component.
- EPSS probability
- 9.65% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 95.2% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2023-09-19 07:01Z3 YR AGO
- Last updated
- 2026-10-28 11:39Z1 DAY AGO
- Reserved
- 2023-09-15
- Assigning CNA
- GitLab
- Record state
- PUBLISHED
- Severity
- High (CVSS 8.2)
- CNA CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-863Incorrect AuthorizationClass
- Data version
- 5.2
- Document digest
- df89d3fdfee539dd43346929b9590aa63cca6619acd6d0e4775b59c204f1588e
05 Affected products
VendorProductVersionsPlatforms
06 References
- gitlab.comGitLab Issue #425304https://gitlab.com/gitlab-org/gitlab/-/issues/425304
- hackerone.comHackerOne Bug Bounty Report #2147126https://hackerone.com/reports/2147126
07 Remediation
Upgrade to versions 16.2.7, 16.3.4 or above For those users unable to upgrade for those versions, you can mitigate the vulnerability by having at most one of those two features turned on at one time: - [Direct transfers](https://docs.gitlab.com/ee/administration/settings/import_and_export_settings.html#enable-migration-of-groups-and-projects-by-direct-transfer) - [Security policies](https://docs.gitlab.com/ee/user/application_security/policies/scan-execution-policies.html)