01 Record
CVE-2023-23812
WordPress Enhanced WP Contact Form Plugin <= 2.2.3 is vulnerable to Cross Site Scripting (XSS)
MediumPUBLISHEDCNA: Patchstack
CNA base score5.9 CVSS v3.xCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
02 Description
WordPress Enhanced WP Contact Form Plugin <= 2.2.3 is vulnerable to Cross Site Scripting (XSS)
03 Exploitation and scoring
- Exploitation
- Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
- SSVC decision
- ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
- AutomatablenoAt least one step from reconnaissance to exploitation cannot be reliably automated.
- Technical ImpactpartialSuccessful exploitation gives limited control of the vulnerable component.
- EPSS probability
- 0.36% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 30.5% of scored records. A rank, not a probability.
- NVD base score
- 4.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2023-05-10 07:38Z3 YR AGO
- Last updated
- 2026-04-28 16:08Z6 MO AGO
- Reserved
- 2023-01-18
- Assigning CNA
- Patchstack
- Record state
- PUBLISHED
- Severity
- Medium (CVSS 5.9)
- CNA CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.2
- Document digest
- 76c0320b991f9d62a326d6b1fbeef91679b24a48863494bf812e894f41e740ab
05 Affected products
VendorProductVersionsPlatforms
06 References
07 Remediation
The vulnerability was patched in the 2.3 version. However, you should look for alternative software as the author no longer supports this plugin, and it has been removed from the WordPress repository.