CVE-2022-30688
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges
02 Description
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 0.39% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 33.6% of scored records. A rank, not a probability.
- NVD base score
- 7.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2022-05-17 18:58Z4 YR AGO
- Last updated
- 2025-11-03 21:46Z11 MO AGO
- Reserved
- 2022-05-13
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- No CWE assigned
- Data version
- 5.2
- Document digest
- a09ad320dc75e93689a212bc994568d03f9c926696049f95619cf5e2abdf6838
05 Affected products
06 References
- github.comhttps://github.com/liske/needrestart/releases/tag/v3.6
- github.comhttps://github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30
- lists.debian.orghttps://lists.debian.org/debian-security-announce/2022/msg00105.html
- www.openwall.comhttps://www.openwall.com/lists/oss-security/2022/05/17/9
- www.openwall.com[oss-security] 20220517 CVE-2022-30688: needrestart 0.8+ local privilege escalationhttp://www.openwall.com/lists/oss-security/2022/05/17/9
- www.debian.orgDSA-5137https://www.debian.org/security/2022/dsa-5137
- lists.debian.org[debian-lts-announce] 20220518 [SECURITY] [DLA 3013-1] needrestart security updatehttps://lists.debian.org/debian-lts-announce/2022/05/msg00024.html
- seclists.orghttp://seclists.org/fulldisclosure/2024/Nov/17
- seclists.orghttp://seclists.org/fulldisclosure/2024/Nov/15
07 Fixed in
Debian 12
- needrestart Fixed in 3.6-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- needrestart Fixed in 3.6-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- needrestart Fixed in 3.6-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- needrestart Fixed in 3.1-1ubuntu0.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 20.04 LTS
- needrestart Fixed in 3.4-6ubuntu0.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 22.04 LTS
- needrestart Fixed in 3.5-5ubuntu2.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 16.04 LTS
- needrestart No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.