synced 10 MIN AGO
01 Record

CVE-2021-3840

A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in

HighPUBLISHEDCNA: lenovo
CNA base score8.8 CVSS v3.xCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

02 Description

A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
2.03% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 80.6% of scored records. A rank, not a probability.
NVD base score
8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
No Red Hat rating. Red Hat rates the CVEs that affect its products.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2021-11-12 22:05Z4 YR AGO
Last updated
2024-08-03 17:09Z2 YR AGO
Reserved
2021-09-29
Assigning CNA
lenovo
Record state
PUBLISHED
Severity
High (CVSS 8.8)
CNA CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
  • CWE-427Uncontrolled Search Path ElementBase
Data version
5.1
Document digest
04f9b72d04a3f0654df073944afc5739faa4fb081f0a1ab940362569a9488925

05 Affected products

VendorProductVersionsPlatforms
AntillesAntilles< 1.0.1—

06 References

07 Remediation

Remove previous versions of Antilles as a precautionary measure and Update to version 1.0.1 or later.