CVE-2021-3393
An information leak was discovered in postgresql in versions before 13.2, before 12.6 and before 11.11. A user having UPDATE permission but not SELECT permission to a particular column could craft
02 Description
An information leak was discovered in postgresql in versions before 13.2, before 12.6 and before 11.11. A user having UPDATE permission but not SELECT permission to a particular column could craft
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.18% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 67.7% of scored records. A rank, not a probability.
- NVD base score
- 4.3 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Low. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2021-04-01 13:46Z5 YR AGO
- Last updated
- 2024-08-03 16:53Z2 YR AGO
- Reserved
- 2021-02-02
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-209Generation of Error Message Containing Sensitive InformationBase
- Data version
- 5.1
- Document digest
- be27d5f80d16d472f740eff13aca1c283279567b61ffe6eaef2bcd695b898a81
05 Affected products
06 References
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=1924005
- security.netapp.comhttps://security.netapp.com/advisory/ntap-20210507-0006/
- security.gentoo.orgGLSA-202105-32https://security.gentoo.org/glsa/202105-32
07 Fixed in
AlmaLinux 8
- postgres-decoderbufs Fixed
A version is affected if any line below covers it.
- Affected before 0.10.0-2.module_el8.6.0+2758+4f4474df
- Affected before 0.10.0-2.module_el8.6.0+2760+1746ec94
Source: AlmaLinux, AlmaLinux OS. Copyright (c) 2023 AlmaLinux OS. Licensed under MIT License. Received through OSV.dev. Reformatted by exploit.cc.
Arch Linux
- postgresql Fixed in 13.2-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
CloudLinux 8
- postgres-decoderbufs Fixed
A version is affected if any line below covers it.
- Affected before 0.10.0-2.module_el8.6.0+2758+4f4474df
- Affected before 0.10.0-2.module_el8.6.0+2760+1746ec94
Derived from AlmaLinux 8. Partial coverage: only packages taken from AlmaLinux 8 are listed.
Source: CloudLinux errata, CloudLinux Inc. Derived from: AlmaLinux, AlmaLinux OS. Copyright (c) 2023 AlmaLinux OS. Licensed under MIT License. Received through OSV.dev. Reformatted by exploit.cc.
Debian 11
- postgresql-13 Fixed in 13.2-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 20.04 LTS
- postgresql-12 Fixed in 12.6-0ubuntu0.20.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.