CVE-2021-3185
A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could cause the stack to be smashed, memory corruption and possibly
02 Description
A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could cause the stack to be smashed, memory corruption and possibly
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.48% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 84.3% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2021-01-25 16:33Z5 YR AGO
- Last updated
- 2024-08-03 16:45Z2 YR AGO
- Reserved
- 2021-01-20
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- e421296e258c16e86e85ef5207c44fbc62a3e65355cac91b97cc57a0703f42ed
05 Affected products
06 References
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=1917192
- security.gentoo.orgGLSA-202208-31https://security.gentoo.org/glsa/202208-31
07 Fixed in
Arch Linux
- gst-plugins-bad Fixed in 1.18.0+54+gbd3532008-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Debian 12
- gst-plugins-bad1.0 Fixed in 1.18.1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- gst-plugins-bad1.0 Fixed in 1.18.1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- gst-plugins-bad1.0 Fixed in 1.18.1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 14.04 LTS
- gst-plugins-bad1.0 No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 16.04 LTS
- gst-plugins-bad1.0 No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 18.04 LTS
- gst-plugins-bad1.0 No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.