CVE-2021-30130
phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
02 Description
phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.05% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 64.2% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2021-04-06 00:00Z5 YR AGO
- Last updated
- 2024-08-03 22:24Z2 YR AGO
- Reserved
- 2021-04-05
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-347Improper Verification of Cryptographic SignatureBase
- Data version
- 5.1
- Document digest
- 1889a27756b491c69b0cf65f4ab49efa4b3b7e7cb68409231346d65725833c17
05 Affected products
06 References
- github.comhttps://github.com/phpseclib/phpseclib/pull/1635
- github.comhttps://github.com/phpseclib/phpseclib/releases/tag/3.0.7
- github.comhttps://github.com/phpseclib/phpseclib/releases/tag/2.0.31
- lists.debian.org[debian-lts-announce] 20221117 [SECURITY] [DLA 3197-1] phpseclib security updatehttps://lists.debian.org/debian-lts-announce/2022/11/msg00024.html
- lists.debian.org[debian-lts-announce] 20221117 [SECURITY] [DLA 3198-1] php-phpseclib security updatehttps://lists.debian.org/debian-lts-announce/2022/11/msg00025.html
07 Fixed in
Debian 12
- php-phpseclib Fixed in 2.0.30-2
- php-phpseclib3 Fixed in 3.0.7-1
- phpseclib Fixed in 1.0.19-3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- php-phpseclib Fixed in 2.0.30-2
- php-phpseclib3 Fixed in 3.0.7-1
- phpseclib Fixed in 1.0.19-3
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- php-phpseclib Fixed in 2.0.30-2
- php-phpseclib3 Fixed in 3.0.7-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 20.04 LTS
- php-phpseclib Fixed in 2.0.23-2ubuntu0.1~esm2Available with Ubuntu Pro: https://ubuntu.com/pro
- phpseclib Fixed in 1.0.18-2ubuntu0.1~esm1Available with Ubuntu Pro: https://ubuntu.com/pro
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.