synced 14 MIN AGO
01 Record

CVE-2021-28503

In Arista's EOS software affected releases, eAPI might skip re-evaluating user credentials when certificate based authentication is used, which allows remote attackers to access the device via eAPI.

HighPUBLISHEDCNA: Arista
CNA base score7.4 CVSS v3.xCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H

02 Description

In Arista's EOS software affected releases, eAPI might skip re-evaluating user credentials when certificate based authentication is used, which allows remote attackers to access the device via eAPI.

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
0.73% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 53.9% of scored records. A rank, not a probability.
NVD base score
9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
No Red Hat rating. Red Hat rates the CVEs that affect its products.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2022-02-04 22:29Z4 YR AGO
Last updated
2024-09-16 23:06Z2 YR AGO
Reserved
2021-03-16
Assigning CNA
Arista
Record state
PUBLISHED
Severity
High (CVSS 7.4)
CNA CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
Weaknesses
  • CWE-305Authentication Bypass by Primary WeaknessBase
  • CWE-287Improper AuthenticationClass
Data version
5.1
Document digest
a00fa337061ab1d888893d1bd040518419a3166eda27a32702b1fb24ead87c46

05 Affected products

VendorProductVersionsPlatforms
Arista NetworksArista EOSEOS-4.23 to < EOS-4.23.10, EOS-4.24 to < EOS-4.24.8, EOS-4.25 to < EOS-4.25.6, EOS-4.26 to < EOS-4.26.3—

06 References

07 Remediation

The recommended resolution is to upgrade to a remediated software version at your earliest convenience. The vulnerability is fixed in the following EOS versions: 4.26.3 and later releases in the 4.26.x train 4.25.6 and later releases in the 4.25.x train 4.24.8 and later releases in the 4.24.x train 4.23.10 and later releases in the 4.24.x train