synced 3 MIN AGO
01 Record

CVE-2020-8205

The uppy npm package < 1.13.2 and < 2.0.0-alpha.5 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external networks or otherwise interact

UnratedPUBLISHEDCNA: hackerone
CNA base scoreUnratedNo CNA CVSS vector

02 Description

The uppy npm package < 1.13.2 and < 2.0.0-alpha.5 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external networks or otherwise interact

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
1.19% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 67.3% of scored records. A rank, not a probability.
NVD base score
7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
No Red Hat rating. Red Hat rates the CVEs that affect its products.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2020-07-20 15:00Z6 YR AGO
Last updated
2024-08-04 09:56Z2 YR AGO
Reserved
2020-01-28
Assigning CNA
hackerone
Record state
PUBLISHED
Severity
Not rated by the issuing CNA
CNA CVSS vector
Not published by the issuing CNA
Weaknesses
  • CWE-918Server-Side Request Forgery (SSRF)Base
Data version
5.1
Document digest
4b3815879e26f3c9b37258c64356a760aacf52c170d21a991cd6a0a1ac8ea356

05 Affected products

VendorProductVersionsPlatforms
n/auppyFixed Versions: 1.13.2, 2.0.0-alpha.5—

06 References