synced 12 MIN AGO
01 Record

CVE-2020-4049

Authenticated self-XSS via theme uploads in WordPress

LowPUBLISHEDCNA: GitHub_M
CNA base score2.4 CVSS v3.xCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N

02 Description

Authenticated self-XSS via theme uploads in WordPress

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
2.53% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 84.7% of scored records. A rank, not a probability.
NVD base score
2.4 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
No Red Hat rating. Red Hat rates the CVEs that affect its products.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2020-06-12 16:00Z6 YR AGO
Last updated
2024-08-04 07:52Z2 YR AGO
Reserved
2019-12-30
Assigning CNA
GitHub_M
Record state
PUBLISHED
Severity
Low (CVSS 2.4)
CNA CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
Weaknesses
  • CWE-80Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)Variant
  • CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
Data version
5.1
Document digest
032cb742e4952f402ac41f59c40af63867415ed5d9269c4a83b660ca91be0189

05 Affected products

VendorProductVersionsPlatforms
WordPresswordpress-develop>= 5.4.0, < 5.4.2, >= 5.3.0, < 5.3.4, >= 5.2.0, < 5.2.7, >= 5.1.0, < 5.1.6, >= 5.0.0, < 5.0.10, >= 4.9.0, < 4.9.15, >= 4.8.0, < 4.8.14, >= 4.7.0, < 4.7.18, >= 4.6.0, < 4.6.19, >= 4.5.0, < 4.5.22, >= 4.4.0, < 4.4.23, >= 4.3.0, < 4.3.24, >= 4.2.0, < 4.2.28, >= 4.1.0, < 4.1.31, >= 4.0.0, < 4.0.31, >= 3.9.0, < 3.9.32, >= 3.8.0, < 3.8.34, >= 3.7.0, < 3.7.34—

06 References

07 Fixed in

Debian 12

  • wordpress
    Fixed in 5.4.2+dfsg1-1

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

Debian 13

  • wordpress
    Fixed in 5.4.2+dfsg1-1

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

Debian 14

  • wordpress
    Fixed in 5.4.2+dfsg1-1

Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 16.04 LTS

  • wordpress
    No fix yet

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 18.04 LTS

  • wordpress
    No fix yet

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 20.04 LTS

  • wordpress
    No fix yet

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 22.04 LTS

  • wordpress
    No fix yet

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.