CVE-2020-1720
A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub-commands did not perform authorization checks. An authenticated attacker could use this flaw in certain configurations to
02 Description
A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub-commands did not perform authorization checks. An authenticated attacker could use this flaw in certain configurations to
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.18% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 67.1% of scored records. A rank, not a probability.
- NVD base score
- 6.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Low. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2020-03-17 15:28Z6 YR AGO
- Last updated
- 2024-08-04 06:46Z2 YR AGO
- Reserved
- 2019-11-27
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Low (CVSS 3.1)
- CNA CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- Data version
- 5.1
- Document digest
- 075819ddc60378dd8e55626ec90e109ddd477a73a19b0652b97ce1d663ea4579
05 Affected products
06 References
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1720
- www.postgresql.orghttps://www.postgresql.org/about/news/2011/
- lists.opensuse.orgopenSUSE-SU-2020:1227http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
07 Fixed in
AlmaLinux 8
- postgres-decoderbufs Fixed
A version is affected if any line below covers it.
- Affected before 0.10.0-2.module_el8.6.0+2758+4f4474df
- Affected before 0.10.0-2.module_el8.6.0+2760+1746ec94
Source: AlmaLinux, AlmaLinux OS. Copyright (c) 2023 AlmaLinux OS. Licensed under MIT License. Received through OSV.dev. Reformatted by exploit.cc.
CloudLinux 8
- postgres-decoderbufs Fixed
A version is affected if any line below covers it.
- Affected before 0.10.0-2.module_el8.6.0+2758+4f4474df
- Affected before 0.10.0-2.module_el8.6.0+2760+1746ec94
Derived from AlmaLinux 8. Partial coverage: only packages taken from AlmaLinux 8 are listed.
Source: CloudLinux errata, CloudLinux Inc. Derived from: AlmaLinux, AlmaLinux OS. Copyright (c) 2023 AlmaLinux OS. Licensed under MIT License. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- postgresql-10 Fixed in 10.12-0ubuntu0.18.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.