synced 11 MIN AGO
01 Record

CVE-2020-14350

It was found that some PostgreSQL extensions did not use search_path safely in their installation script. An attacker with sufficient privileges could use this flaw to trick an administrator into

UnratedPUBLISHEDCNA: redhat
CNA base scoreUnratedNo CNA CVSS vector

02 Description

It was found that some PostgreSQL extensions did not use search_path safely in their installation script. An attacker with sufficient privileges could use this flaw to trick an administrator into

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
0.53% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 44.6% of scored records. A rank, not a probability.
NVD base score
7.3 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
Moderate. Red Hat's rating for its own products, not a CVSS rating.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2020-08-24 12:42Z6 YR AGO
Last updated
2024-08-04 12:39Z2 YR AGO
Reserved
2020-06-17
Assigning CNA
redhat
Record state
PUBLISHED
Severity
Not rated by the issuing CNA
CNA CVSS vector
Not published by the issuing CNA
Weaknesses
  • CWE-426Untrusted Search PathBase
  • CWE-20Improper Input ValidationClass
Data version
5.1
Document digest
85ebbf51547687ae4a092eb1fe700f1766d7123414c6b0862cfab4881c0eead3

05 Affected products

VendorProductVersionsPlatforms
n/aPostgreSQLPostgreSQL versions before 12.4, before 11.9, before 10.14, before 9.6.19, and before 9.5.23—

06 References

07 Fixed in

AlmaLinux 8

  • postgres-decoderbufs
    Fixed

    A version is affected if any line below covers it.

    • Affected before 0.10.0-2.module_el8.6.0+2758+4f4474df
    • Affected before 0.10.0-2.module_el8.6.0+2760+1746ec94

Source: AlmaLinux, AlmaLinux OS. Copyright (c) 2023 AlmaLinux OS. Licensed under MIT License. Received through OSV.dev. Reformatted by exploit.cc.

CloudLinux 8

  • postgres-decoderbufs
    Fixed

    A version is affected if any line below covers it.

    • Affected before 0.10.0-2.module_el8.6.0+2758+4f4474df
    • Affected before 0.10.0-2.module_el8.6.0+2760+1746ec94

Derived from AlmaLinux 8. Partial coverage: only packages taken from AlmaLinux 8 are listed.

Source: CloudLinux errata, CloudLinux Inc. Derived from: AlmaLinux, AlmaLinux OS. Copyright (c) 2023 AlmaLinux OS. Licensed under MIT License. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 16.04 LTS

  • postgresql-9.5
    Fixed in 9.5.23-0ubuntu0.16.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 18.04 LTS

  • postgresql-10
    Fixed in 10.14-0ubuntu0.18.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 20.04 LTS

  • postgresql-12
    Fixed in 12.4-0ubuntu0.20.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu Pro 14.04 LTS

  • postgresql-9.3
    No fix yet

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.