CVE-2019-9787
WordPress before 5.1.1 does not properly filter comment content, leading to Remote Code Execution by unauthenticated users in a default configuration. This occurs because CSRF protection is
02 Description
WordPress before 5.1.1 does not properly filter comment content, leading to Remote Code Execution by unauthenticated users in a default configuration. This occurs because CSRF protection is
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 38.55% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 98.5% of scored records. A rank, not a probability.
- NVD base score
- 8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-03-14 16:00Z7 YR AGO
- Last updated
- 2024-08-04 22:01Z2 YR AGO
- Reserved
- 2019-03-14
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-352Cross-Site Request Forgery (CSRF)Compound
- Data version
- 5.1
- Document digest
- 59947dacc8fa6c75eede00b1114376ad0283c6e0193eb6a5cbb6363e86f6c0d1
05 Affected products
06 References
- blog.ripstech.comhttps://blog.ripstech.com/2019/wordpress-csrf-to-rce/
- wordpress.orghttps://wordpress.org/news/2019/03/wordpress-5-1-1-security-and-maintenance-release/
- github.comhttps://github.com/WordPress/WordPress/commit/0292de60ec78c5a44956765189403654fe4d080b
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/9230
- www.securityfocus.com107411http://www.securityfocus.com/bid/107411
- wordpress.orghttps://wordpress.org/support/wordpress-version/version-5-1-1/
- lists.debian.org[debian-lts-announce] 20190331 [SECURITY] [DLA 1742-1] wordpress security updatehttps://lists.debian.org/debian-lts-announce/2019/03/msg00044.html
- www.debian.orgDSA-4677https://www.debian.org/security/2020/dsa-4677
07 Fixed in
Debian 12
- wordpress Fixed in 5.1.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 5.1.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 5.1.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.