CVE-2019-8942
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php
02 Description
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 82.73% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 99.6% of scored records. A rank, not a probability.
- NVD base score
- 8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-02-20 03:00Z7 YR AGO
- Last updated
- 2024-08-04 21:31Z2 YR AGO
- Reserved
- 2019-02-19
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-434Unrestricted Upload of File with Dangerous TypeBase
- Data version
- 5.1
- Document digest
- 5fef6c76ea8dbcd831914b07edb46c052cd5bbb60df9448a8c29b9362f0e22e1
05 Affected products
06 References
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/9222
- www.exploit-db.com46511https://www.exploit-db.com/exploits/46511/
- www.securityfocus.com107088http://www.securityfocus.com/bid/107088
- blog.ripstech.comhttps://blog.ripstech.com/2019/wordpress-image-remote-code-execution/
- www.debian.orgDSA-4401https://www.debian.org/security/2019/dsa-4401
- lists.debian.org[debian-lts-announce] 20190331 [SECURITY] [DLA 1742-1] wordpress security updatehttps://lists.debian.org/debian-lts-announce/2019/03/msg00044.html
- packetstormsecurity.comhttp://packetstormsecurity.com/files/152396/WordPress-5.0.0-crop-image-Shell-Upload.html
- www.rapid7.comhttp://www.rapid7.com/db/modules/exploit/multi/http/wp_crop_rce
- www.exploit-db.com46662https://www.exploit-db.com/exploits/46662/
07 Fixed in
Arch Linux
- wordpress Fixed in 5.0.1-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Debian 12
- wordpress Fixed in 5.0.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 5.0.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 5.0.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.