synced 4 MIN AGO
01 Record

CVE-2019-19757

An internal product security audit of Lenovo XClarity Administrator (LXCA) discovered a Document Object Model (DOM) based cross-site scripting vulnerability in versions prior to 2.6.6 that could allow

MediumPUBLISHEDCNA: lenovo
CNA base score5.4 CVSS v3.xCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

02 Description

An internal product security audit of Lenovo XClarity Administrator (LXCA) discovered a Document Object Model (DOM) based cross-site scripting vulnerability in versions prior to 2.6.6 that could allow

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
0.52% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 43.9% of scored records. A rank, not a probability.
NVD base score
5.4 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
No Red Hat rating. Red Hat rates the CVEs that affect its products.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2020-02-14 17:10Z6 YR AGO
Last updated
2024-09-16 19:40Z2 YR AGO
Reserved
2019-12-12
Assigning CNA
lenovo
Record state
PUBLISHED
Severity
Medium (CVSS 5.4)
CNA CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
  • CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
Data version
5.1
Document digest
95d5c0d7b138abebc3d5b5a11177e285c7139bf664a0a7d6163093b8146b7813

05 Affected products

VendorProductVersionsPlatforms

06 References

07 Remediation

Update your LXCA installation to version 2.6.6 or later. Installation note: You will need to update to LXCA 2.6.0 before installing the latest fix bundle (v 2.6.6).