CVE-2019-17671
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
02 Description
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 36.50% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 98.3% of scored records. A rank, not a probability.
- NVD base score
- 5.3 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-10-17 12:04Z7 YR AGO
- Last updated
- 2024-08-05 01:47Z2 YR AGO
- Reserved
- 2019-10-17
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-200Exposure of Sensitive Information to an Unauthorized ActorClass
- Data version
- 5.1
- Document digest
- c1f681dfeb3f5e77a032fe9e4a83011352d54d4e48c51281306d363680c04589
05 Affected products
06 References
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/9909
- blog.wpscan.orghttps://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- wordpress.orghttps://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
- core.trac.wordpress.orghttps://core.trac.wordpress.org/changeset/46474
- github.comhttps://github.com/WordPress/WordPress/commit/f82ed753cf00329a5e41f2cb6dc521085136f308
- lists.debian.org[debian-lts-announce] 20191105 [SECURITY] [DLA 1980-1] wordpress security updatehttps://lists.debian.org/debian-lts-announce/2019/11/msg00000.html
- seclists.org20200108 [SECURITY] [DSA 4599-1] wordpress security updatehttps://seclists.org/bugtraq/2020/Jan/8
- www.debian.orgDSA-4599https://www.debian.org/security/2020/dsa-4599
- www.debian.orgDSA-4677https://www.debian.org/security/2020/dsa-4677
07 Fixed in
Debian 12
- wordpress Fixed in 5.2.4+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 5.2.4+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 5.2.4+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.