CVE-2019-17669
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because URL validation does not consider the interpretation of a name as a series of hex characters.
02 Description
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because URL validation does not consider the interpretation of a name as a series of hex characters.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 5.24% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 92.3% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-10-17 12:03Z7 YR AGO
- Last updated
- 2024-08-05 01:47Z2 YR AGO
- Reserved
- 2019-10-17
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-918Server-Side Request Forgery (SSRF)Base
- Data version
- 5.1
- Document digest
- 68602f2759c6ee39d4a2bfd2d025908c0a3640b24a29e6c0b7439e431059f7cf
05 Affected products
06 References
- blog.wpscan.orghttps://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- wordpress.orghttps://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
- core.trac.wordpress.orghttps://core.trac.wordpress.org/changeset/46475
- github.comhttps://github.com/WordPress/WordPress/commit/608d39faed63ea212b6c6cdf9fe2bef92e2120ea
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/9912
- lists.debian.org[debian-lts-announce] 20191105 [SECURITY] [DLA 1980-1] wordpress security updatehttps://lists.debian.org/debian-lts-announce/2019/11/msg00000.html
- seclists.org20200108 [SECURITY] [DSA 4599-1] wordpress security updatehttps://seclists.org/bugtraq/2020/Jan/8
- www.debian.orgDSA-4599https://www.debian.org/security/2020/dsa-4599
- www.debian.orgDSA-4677https://www.debian.org/security/2020/dsa-4677
07 Fixed in
Debian 12
- wordpress Fixed in 5.2.4+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 5.2.4+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 5.2.4+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.