CVE-2019-17266
libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding
02 Description
libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.78% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 86.1% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Important. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-10-06 21:48Z7 YR AGO
- Last updated
- 2024-08-05 01:33Z2 YR AGO
- Reserved
- 2019-10-06
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-125Out-of-bounds ReadBase
- Data version
- 5.1
- Document digest
- 1807aac588600300e4de724aade351f6316b1e93b0e0ec872be2062cbd7fea79
05 Affected products
06 References
- gitlab.gnome.orghttps://gitlab.gnome.org/GNOME/libsoup/issues/173
- security-tracker.debian.orghttps://security-tracker.debian.org/tracker/CVE-2019-17266
- gitlab.gnome.orghttps://gitlab.gnome.org/GNOME/libsoup/commit/88b7dff4467f4151afae244ea7d1223753cd05ab
- github.comhttps://github.com/Kirin-say/Vulnerabilities/blob/master/CVE-2019-17266_POC.md
- bugs.debian.orghttps://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941912
- www.mail-archive.comhttps://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1705054.html
- gitlab.gnome.orghttps://gitlab.gnome.org/GNOME/libsoup/commit/f8a54ac85eec2008c85393f331cdd251af8266ad
- usn.ubuntu.comUSN-4152-1https://usn.ubuntu.com/4152-1/
07 Fixed in
Debian 12
- libsoup2.4 Fixed in 2.68.2-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- libsoup2.4 Fixed in 2.68.2-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- libsoup2.4 Fixed in 2.62.1-1ubuntu0.4
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.