CVE-2019-10208
A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given
02 Description
A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.18% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 82.2% of scored records. A rank, not a probability.
- NVD base score
- 8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-10-29 13:13Z7 YR AGO
- Last updated
- 2024-08-04 22:17Z2 YR AGO
- Reserved
- 2019-03-27
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- High (CVSS 7.5)
- CNA CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')Base
- Data version
- 5.1
- Document digest
- 03e839eb60165e5b66c6360a73c7c8093836929ec6161deb0640e239af96e828
05 Affected products
06 References
- www.postgresql.orghttps://www.postgresql.org/about/news/1960/
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10208
- lists.opensuse.orgopenSUSE-SU-2020:1227http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
07 Fixed in
Arch Linux
- postgresql Fixed in 11.5-1
- postgresql-libs Fixed in 11.5-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- postgresql-9.5 Fixed in 9.5.19-0ubuntu0.16.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- postgresql-10 Fixed in 10.10-0ubuntu0.18.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 14.04 LTS
- postgresql-9.3 No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.