CVE-2019-10206
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain
02 Description
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.51% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 73.9% of scored records. A rank, not a probability.
- NVD base score
- 6.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-11-22 00:00Z6 YR AGO
- Last updated
- 2024-08-04 22:17Z2 YR AGO
- Reserved
- 2019-03-27
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Medium (CVSS 6.4)
- CNA CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-522Insufficiently Protected CredentialsClass
- Data version
- 5.1
- Document digest
- e1c48caabb65ea7c8d6f70b2fe24a6bd70cb124f90d8298587c4080efccc081d
05 Affected products
06 References
- lists.opensuse.orgopenSUSE-SU-2020:0513http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- lists.opensuse.orgopenSUSE-SU-2020:0523http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- www.debian.orgDSA-4950https://www.debian.org/security/2021/dsa-4950
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206
- lists.debian.org[debian-lts-announce] 20231228 [SECURITY] [DLA 3695-1] ansible security updatehttps://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
07 Fixed in
Debian 12
- ansible Fixed in 2.8.6+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- ansible Fixed in 2.8.6+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- ansible Fixed in 2.8.6+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 16.04 LTS
- ansible Fixed in 2.0.0.2-2ubuntu1.3+esm5Available with Ubuntu Pro: https://ubuntu.com/pro
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 18.04 LTS
- ansible Fixed in 2.5.1+dfsg-1ubuntu0.1+esm5Available with Ubuntu Pro: https://ubuntu.com/pro
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.