CVE-2018-20150
In WordPress before 4.9.9 and 5.x before 5.0.1, crafted URLs could trigger XSS for certain use cases involving plugins.
02 Description
In WordPress before 4.9.9 and 5.x before 5.0.1, crafted URLs could trigger XSS for certain use cases involving plugins.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 4.24% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 90.6% of scored records. A rank, not a probability.
- NVD base score
- 6.1 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-12-14 20:00Z7 YR AGO
- Last updated
- 2024-08-05 11:51Z2 YR AGO
- Reserved
- 2018-12-14
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.1
- Document digest
- f703c0196c7a24b2a20114f0c9687f5848ef752a4248e765ed1b8cb69011a987
05 Affected products
06 References
- www.securityfocus.com106220http://www.securityfocus.com/bid/106220
- wordpress.orghttps://wordpress.org/support/wordpress-version/version-5-0-1/
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.9.9
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/9173
- github.comhttps://github.com/WordPress/WordPress/commit/fb3c6ea0618fcb9a51d4f2c1940e9efcd4a2d460
- www.debian.orgDSA-4401https://www.debian.org/security/2019/dsa-4401
- wordpress.orghttps://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/
- lists.debian.org[debian-lts-announce] 20190211 [SECURITY] [DLA 1673-1] wordpress security updatehttps://lists.debian.org/debian-lts-announce/2019/02/msg00019.html
- www.zdnet.comhttps://www.zdnet.com/article/wordpress-plugs-bug-that-led-to-google-indexing-some-user-passwords/
07 Fixed in
Debian 12
- wordpress Fixed in 5.0.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 5.0.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 5.0.1+dfsg1-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.