CVE-2018-17937
gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded
02 Description
gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.65% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 85.3% of scored records. A rank, not a probability.
- NVD base score
- 8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2019-03-13 17:00Z7 YR AGO
- Last updated
- 2024-09-16 19:36Z2 YR AGO
- Reserved
- 2018-10-02
- Assigning CNA
- icscert
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- e95fc7482382fcfb40b402618747ff4bca8484f91a422f3bdb2572f76d9244f8
05 Affected products
06 References
- www.securityfocus.com107029http://www.securityfocus.com/bid/107029
- ics-cert.us-cert.govhttps://ics-cert.us-cert.gov/advisories/ICSA-18-310-01
- lists.debian.org[debian-lts-announce] 20190330 [SECURITY] [DLA 1738-1] gpsd security updatehttps://lists.debian.org/debian-lts-announce/2019/03/msg00040.html
- security.gentoo.orgGLSA-202009-17https://security.gentoo.org/glsa/202009-17
- lists.debian.org[debian-lts-announce] 20211029 [SECURITY] [DLA 2795-1] gpsd security updatehttps://lists.debian.org/debian-lts-announce/2021/10/msg00024.html
07 Fixed in
Debian 12
- gpsd Fixed in 3.17-6
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- gpsd Fixed in 3.17-6
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- gpsd Fixed in 3.17-6
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- gpsd No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- gpsd No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.