CVE-2018-17082
The Apache2 component in PHP before 5.6.38, 7.0.x before 7.0.32, 7.1.x before 7.1.22, and 7.2.x before 7.2.10 allows XSS via the body of a "Transfer-Encoding: chunked" request, because the bucket
02 Description
The Apache2 component in PHP before 5.6.38, 7.0.x before 7.0.32, 7.1.x before 7.1.22, and 7.2.x before 7.2.10 allows XSS via the body of a "Transfer-Encoding: chunked" request, because the bucket
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 4.10% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 90.3% of scored records. A rank, not a probability.
- NVD base score
- 6.1 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-09-16 15:00Z8 YR AGO
- Last updated
- 2024-08-05 10:39Z2 YR AGO
- Reserved
- 2018-09-16
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.1
- Document digest
- 4601c37a4af21aef2dbca4bf8ee1937fcb12a310c61cd0293815912067864ddb
05 Affected products
06 References
- php.nethttp://php.net/ChangeLog-5.php
- php.nethttp://php.net/ChangeLog-7.php
- www.debian.orgDSA-4353https://www.debian.org/security/2018/dsa-4353
- github.comhttps://github.com/php/php-src/commit/23b057742e3cf199612fa8050ae86cae675e214e
- lists.debian.org[debian-lts-announce] 20180920 [SECURITY] [DLA 1509-1] php5 security updatehttps://lists.debian.org/debian-lts-announce/2018/09/msg00020.html
- bugs.php.nethttps://bugs.php.net/bug.php?id=76582
- security.gentoo.orgGLSA-201812-01https://security.gentoo.org/glsa/201812-01
- security.netapp.comhttps://security.netapp.com/advisory/ntap-20180924-0001/
- access.redhat.comRHSA-2019:2519https://access.redhat.com/errata/RHSA-2019:2519
- www.tenable.comhttps://www.tenable.com/security/tns-2019-07
07 Fixed in
Ubuntu 14.04 LTS
- php5 Fixed in 5.5.9+dfsg-1ubuntu4.26
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- php7.0 Fixed in 7.0.32-0ubuntu0.16.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- php7.2 Fixed in 7.2.10-0ubuntu0.18.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.