CVE-2018-1115
postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is
02 Description
postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is
03 Exploitation and scoring
- Exploitation
- Assessed, none found. CISA's assessment recorded neither public exploit code nor evidence of exploitation when it was made.
- SSVC decision
- ExploitationnoneCISA recorded no public exploit code and no evidence of exploitation.
- AutomatableyesAn attacker can reliably automate reconnaissance through exploitation, so this scales.
- Technical ImpactpartialSuccessful exploitation gives limited control of the vulnerable component.
- EPSS probability
- 3.82% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 89.9% of scored records. A rank, not a probability.
- NVD base score
- 9.1 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-10-08.
- Red Hat severity
- Low. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-05-10 19:00Z8 YR AGO
- Last updated
- 2026-10-08 21:24Z20 DAYS AGO
- Reserved
- 2017-12-04
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Medium (CVSS 4.2)
- CNA CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-732Incorrect Permission Assignment for Critical ResourceClass
- Data version
- 5.2
- Document digest
- 5a76b8bce0686416ed2708e8564d456610004af204bce08e37681843bdabf838
05 Affected products
06 References
- security.gentoo.orgGLSA-201810-08https://security.gentoo.org/glsa/201810-08
- access.redhat.comRHSA-2018:2566https://access.redhat.com/errata/RHSA-2018:2566
- access.redhat.comRHSA-2018:2565https://access.redhat.com/errata/RHSA-2018:2565
- www.securityfocus.com104285http://www.securityfocus.com/bid/104285
- lists.opensuse.orgopenSUSE-SU-2020:1227http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1115
- git.postgresql.orghttps://git.postgresql.org/gitweb/?p=postgresql.git%3Ba=commitdiff%3Bh=7b34740
07 Fixed in
Ubuntu 18.04 LTS
- postgresql-10 Fixed in 10.4-0ubuntu0.18.04
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.