CVE-2018-10925
It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statements involved with "INSERT ... ON CONFLICT DO
02 Description
It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statements involved with "INSERT ... ON CONFLICT DO
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.24% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 82.3% of scored records. A rank, not a probability.
- NVD base score
- 8.1 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Important. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2018-08-09 21:00Z8 YR AGO
- Last updated
- 2024-08-05 07:54Z2 YR AGO
- Reserved
- 2018-05-09
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- High (CVSS 7.1)
- CNA CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-863Incorrect AuthorizationClass
- Data version
- 5.1
- Document digest
- 7d99a5d9dff941e601d0746942e58f2505ac748846c7c5b6422fc42cd6e1d31f
05 Affected products
06 References
- security.gentoo.orgGLSA-201810-08https://security.gentoo.org/glsa/201810-08
- www.debian.orgDSA-4269https://www.debian.org/security/2018/dsa-4269
- www.securityfocus.com105052http://www.securityfocus.com/bid/105052
- access.redhat.comRHSA-2018:2511https://access.redhat.com/errata/RHSA-2018:2511
- usn.ubuntu.comUSN-3744-1https://usn.ubuntu.com/3744-1/
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10925
- access.redhat.comRHSA-2018:2566https://access.redhat.com/errata/RHSA-2018:2566
- access.redhat.comRHSA-2018:2565https://access.redhat.com/errata/RHSA-2018:2565
- access.redhat.comRHSA-2018:3816https://access.redhat.com/errata/RHSA-2018:3816
- www.postgresql.orghttps://www.postgresql.org/about/news/1878/
- www.securitytracker.com1041446http://www.securitytracker.com/id/1041446
- lists.opensuse.orgopenSUSE-SU-2020:1227http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
07 Fixed in
Ubuntu 16.04 LTS
- postgresql-9.5 Fixed in 9.5.14-0ubuntu0.16.04
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 18.04 LTS
- postgresql-10 Fixed in 10.5-0ubuntu0.18.04
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.