CVE-2017-7547
PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve passwords from the user mappings defined by
02 Description
PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve passwords from the user mappings defined by
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 5.58% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 92.5% of scored records. A rank, not a probability.
- NVD base score
- 8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-08-16 18:00Z9 YR AGO
- Last updated
- 2024-09-16 23:41Z2 YR AGO
- Reserved
- 2017-04-05
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-522Insufficiently Protected CredentialsClass
- Data version
- 5.1
- Document digest
- efd561dc94067797a0de63433a06075e8eadb8b6b174aac5b60ece92b14f0050
05 Affected products
06 References
- access.redhat.comRHSA-2017:2728https://access.redhat.com/errata/RHSA-2017:2728
- www.debian.orgDSA-3936http://www.debian.org/security/2017/dsa-3936
- access.redhat.comRHSA-2017:2678https://access.redhat.com/errata/RHSA-2017:2678
- www.debian.orgDSA-3935http://www.debian.org/security/2017/dsa-3935
- www.securitytracker.com1039142http://www.securitytracker.com/id/1039142
- www.postgresql.orghttps://www.postgresql.org/about/news/1772/
- security.gentoo.orgGLSA-201710-06https://security.gentoo.org/glsa/201710-06
- www.securityfocus.com100275http://www.securityfocus.com/bid/100275
- access.redhat.comRHSA-2017:2677https://access.redhat.com/errata/RHSA-2017:2677
07 Fixed in
Arch Linux
- postgresql Fixed in 9.6.4-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- postgresql-9.3 Fixed in 9.3.18-0ubuntu0.14.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- postgresql-9.5 Fixed in 9.5.8-0ubuntu0.16.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.