synced JUST NOW
01 Record

CVE-2017-7546

PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts with an empty password.

UnratedPUBLISHEDCNA: redhat
CNA base scoreUnratedNo CNA CVSS vector

02 Description

PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts with an empty password.

03 Exploitation and scoring

Exploitation
Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
SSVC decision
Not assessed by CISA
EPSS probability
61.56% probability of exploitation activity in the next 30 days.
EPSS percentile
Equal to or higher than the score of 99.1% of scored records. A rank, not a probability.
NVD base score
9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
NVD CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD analysis status
Modified. NVD last modified this record on 2026-06-17.
Red Hat severity
Moderate. Red Hat's rating for its own products, not a CVSS rating.

Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.

04 Metadata

Published
2017-08-16 18:00Z9 YR AGO
Last updated
2024-09-16 17:18Z2 YR AGO
Reserved
2017-04-05
Assigning CNA
redhat
Record state
PUBLISHED
Severity
Not rated by the issuing CNA
CNA CVSS vector
Not published by the issuing CNA
Weaknesses
  • CWE-287Improper AuthenticationClass
Data version
5.1
Document digest
db7ad2966ae056aadd648c4a0bbb29d8f6b9fa27461fc406607b4aeaabcd99b5

05 Affected products

VendorProductVersionsPlatforms
PostgreSQLpostgresql9.2.x before 9.2.22, 9.3.x before 9.3.18, 9.4.x before 9.4.13, 9.5.x before 9.5.8, 9.6.x before 9.6.4—

06 References

07 Fixed in

Arch Linux

  • postgresql
    Fixed in 9.6.4-1

Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.

Ubuntu 14.04 LTS

  • postgresql-9.3
    Fixed in 9.3.18-0ubuntu0.14.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

Ubuntu 16.04 LTS

  • postgresql-9.5
    Fixed in 9.5.8-0ubuntu0.16.04.1

Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.

A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.