CVE-2017-7485
In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment variable was no longer enforcing a SSL/TLS connection
02 Description
In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment variable was no longer enforcing a SSL/TLS connection
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.04% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 80.8% of scored records. A rank, not a probability.
- NVD base score
- 5.9 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-05-12 19:00Z9 YR AGO
- Last updated
- 2024-08-05 16:04Z2 YR AGO
- Reserved
- 2017-04-05
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- 81ef821c0ebd69f4e612932c29f8e745e3f36a11b839606db9274453db5c4f21
05 Affected products
06 References
- www.securitytracker.com1038476http://www.securitytracker.com/id/1038476
- www.debian.orgDSA-3851http://www.debian.org/security/2017/dsa-3851
- access.redhat.comRHSA-2017:2425https://access.redhat.com/errata/RHSA-2017:2425
- access.redhat.comRHSA-2017:1678https://access.redhat.com/errata/RHSA-2017:1678
- access.redhat.comRHSA-2017:1677https://access.redhat.com/errata/RHSA-2017:1677
- www.postgresql.orghttps://www.postgresql.org/about/news/1746/
- access.redhat.comRHSA-2017:1838https://access.redhat.com/errata/RHSA-2017:1838
- www.securityfocus.com98461http://www.securityfocus.com/bid/98461
- security.gentoo.orgGLSA-201710-06https://security.gentoo.org/glsa/201710-06
07 Fixed in
Arch Linux
- postgresql-libs Fixed in 9.6.3-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- postgresql-9.3 Fixed in 9.3.17-0ubuntu0.14.04
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- postgresql-9.5 Fixed in 9.5.7-0ubuntu0.16.04
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.