CVE-2017-5611
SQL injection vulnerability in wp-includes/class-wp-query.php in WP_Query in WordPress before 4.7.2 allows remote attackers to execute arbitrary SQL commands by leveraging the presence of an affected
02 Description
SQL injection vulnerability in wp-includes/class-wp-query.php in WP_Query in WordPress before 4.7.2 allows remote attackers to execute arbitrary SQL commands by leveraging the presence of an affected
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 10.20% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 95.5% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-01-30 04:24Z9 YR AGO
- Last updated
- 2024-08-05 15:04Z2 YR AGO
- Reserved
- 2017-01-28
- Assigning CNA
- debian
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-89Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')Base
- Data version
- 5.1
- Document digest
- ffeb34260f88a8465415d36394238d77b652014c97b4c966018b69020fbdc81a
05 Affected products
06 References
- www.securityfocus.com95816http://www.securityfocus.com/bid/95816
- www.debian.orgDSA-3779http://www.debian.org/security/2017/dsa-3779
- www.openwall.com[oss-security] 20170128 Re: CVE Request: Wordpress: 4.7.2 security release: unauthorized bypass, SQL injection, cross-site scripting issueshttp://www.openwall.com/lists/oss-security/2017/01/28/5
- www.securitytracker.com1037731http://www.securitytracker.com/id/1037731
- www.oracle.comhttps://www.oracle.com/security-alerts/cpujan2021.html
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.7.2
- wordpress.orghttps://wordpress.org/news/2017/01/wordpress-4-7-2-security-release/
- github.comhttps://github.com/WordPress/WordPress/commit/85384297a60900004e27e417eac56d24267054cb
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/8730
07 Fixed in
Debian 12
- wordpress Fixed in 4.7.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.7.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.7.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.