CVE-2017-5493
wp-includes/ms-functions.php in the Multisite WordPress API in WordPress before 4.7.1 does not properly choose random numbers for keys, which makes it easier for remote attackers to bypass intended
02 Description
wp-includes/ms-functions.php in the Multisite WordPress API in WordPress before 4.7.1 does not properly choose random numbers for keys, which makes it easier for remote attackers to bypass intended
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.88% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 86.7% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-01-15 02:00Z9 YR AGO
- Last updated
- 2024-08-05 15:04Z2 YR AGO
- Reserved
- 2017-01-14
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-338Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)Base
- Data version
- 5.1
- Document digest
- bc137a4608867adf8f62a0c8951060cf86fb28f23df4476a472a0b838777ec96
05 Affected products
06 References
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/8721
- www.securityfocus.com95401http://www.securityfocus.com/bid/95401
- www.debian.orgDSA-3779http://www.debian.org/security/2017/dsa-3779
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.7.1
- www.openwall.com[oss-security] 20170114 Re: CVE Request: Wordpress: 8 security issues in 4.7http://www.openwall.com/lists/oss-security/2017/01/14/6
- www.securitytracker.com1037591http://www.securitytracker.com/id/1037591
- github.comhttps://github.com/WordPress/WordPress/commit/cea9e2dc62abf777e06b12ec4ad9d1aaa49b29f4
- wordpress.orghttps://wordpress.org/news/2017/01/wordpress-4-7-1-security-and-maintenance-release/
07 Fixed in
Arch Linux
- wordpress Fixed in 4.7.1-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Debian 12
- wordpress Fixed in 4.7.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.7.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.7.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.