CVE-2017-5487
wp-includes/rest-api/endpoints/class-wp-rest-users-controller.php in the REST API implementation in WordPress 4.7 before 4.7.1 does not properly restrict listings of post authors, which allows remote
02 Description
wp-includes/rest-api/endpoints/class-wp-rest-users-controller.php in the REST API implementation in WordPress 4.7 before 4.7.1 does not properly restrict listings of post authors, which allows remote
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 87.29% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 99.7% of scored records. A rank, not a probability.
- NVD base score
- 5.3 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-01-15 02:00Z9 YR AGO
- Last updated
- 2024-08-05 15:04Z2 YR AGO
- Reserved
- 2017-01-14
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-200Exposure of Sensitive Information to an Unauthorized ActorClass
- Data version
- 5.1
- Document digest
- 580a4a7b61d9cb549a63eeb7344eee13928ced96a7639df496f9be00a8e97368
05 Affected products
06 References
- www.exploit-db.com41497https://www.exploit-db.com/exploits/41497/
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/8715
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.7.1
- github.comhttps://github.com/WordPress/WordPress/commit/daf358983cc1ce0c77bf6d2de2ebbb43df2add60
- www.openwall.com[oss-security] 20170114 Re: CVE Request: Wordpress: 8 security issues in 4.7http://www.openwall.com/lists/oss-security/2017/01/14/6
- www.wordfence.comhttps://www.wordfence.com/blog/2016/12/wordfence-blocks-username-harvesting-via-new-rest-api-wp-4-7/
- www.securitytracker.com1037591http://www.securitytracker.com/id/1037591
- wordpress.orghttps://wordpress.org/news/2017/01/wordpress-4-7-1-security-and-maintenance-release/
- www.securityfocus.com95391http://www.securityfocus.com/bid/95391
07 Fixed in
Arch Linux
- wordpress Fixed in 4.7.1-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Debian 12
- wordpress Fixed in 4.7.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.7.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.7.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.