CVE-2017-17784
In GIMP 2.8.22, there is a heap-based buffer over-read in load_image in plug-ins/common/file-gbr.c in the gbr import parser, related to mishandling of UTF-8 data.
02 Description
In GIMP 2.8.22, there is a heap-based buffer over-read in load_image in plug-ins/common/file-gbr.c in the gbr import parser, related to mishandling of UTF-8 data.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.46% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 73.3% of scored records. A rank, not a probability.
- NVD base score
- 7.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-12-20 09:00Z8 YR AGO
- Last updated
- 2024-08-05 20:59Z2 YR AGO
- Reserved
- 2017-12-20
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-125Out-of-bounds ReadBase
- Data version
- 5.1
- Document digest
- 84de33bf8d6f540668cd982adea59215b44e6ab84f7512b15f411d77a5024e94
05 Affected products
06 References
- www.debian.orgDSA-4077https://www.debian.org/security/2017/dsa-4077
- www.securityfocus.com102899http://www.securityfocus.com/bid/102899
- usn.ubuntu.comUSN-3539-1https://usn.ubuntu.com/3539-1/
- www.openwall.comhttp://www.openwall.com/lists/oss-security/2017/12/19/5
- lists.debian.org[debian-lts-announce] 20171223 [SECURITY] [DLA 1220-1] gimp security updatehttps://lists.debian.org/debian-lts-announce/2017/12/msg00023.html
- bugzilla.gnome.orghttps://bugzilla.gnome.org/show_bug.cgi?id=790784
07 Fixed in
Debian 12
- gimp Fixed in 2.8.20-1.1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- gimp Fixed in 2.8.20-1.1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- gimp Fixed in 2.8.20-1.1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 14.04 LTS
- gimp Fixed in 2.8.10-0ubuntu1.2
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 16.04 LTS
- gimp No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.