CVE-2017-17094
wp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.
02 Description
wp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 1.99% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 80.3% of scored records. A rank, not a probability.
- NVD base score
- 5.4 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-12-02 06:00Z8 YR AGO
- Last updated
- 2024-08-05 20:43Z2 YR AGO
- Reserved
- 2017-12-02
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-79Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')Base
- Data version
- 5.1
- Document digest
- ece1b024b63fb172ebf908db498bb4c76b271265a9b4e6f9999a7d0da1a1bf01
05 Affected products
06 References
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/8967
- www.debian.orgDSA-4090https://www.debian.org/security/2018/dsa-4090
- lists.debian.org[debian-lts-announce] 20171221 [SECURITY] [DLA 1216-1] wordpress security updatehttps://lists.debian.org/debian-lts-announce/2017/12/msg00019.html
- www.securityfocus.com102024http://www.securityfocus.com/bid/102024
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.9.1
- wordpress.orghttps://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/
- github.comhttps://github.com/WordPress/WordPress/commit/f1de7e42df29395c3314bf85bff3d1f4f90541de
07 Fixed in
Debian 12
- wordpress Fixed in 4.9.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.9.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.9.1+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.