CVE-2017-16510
WordPress before 4.8.3 is affected by an issue where $wpdb->prepare() can create unexpected and unsafe queries leading to potential SQL injection (SQLi) in plugins and themes, as demonstrated by a
02 Description
WordPress before 4.8.3 is affected by an issue where $wpdb->prepare() can create unexpected and unsafe queries leading to potential SQL injection (SQLi) in plugins and themes, as demonstrated by a
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 6.70% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 93.6% of scored records. A rank, not a probability.
- NVD base score
- 9.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-11-02 16:00Z8 YR AGO
- Last updated
- 2024-08-05 20:27Z2 YR AGO
- Reserved
- 2017-11-02
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-89Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')Base
- Data version
- 5.1
- Document digest
- 06c0fac04cb0b1fdc1e7c3780c252608d35c29b30e53f444d9a039dd3f571de1
05 Affected products
06 References
- github.comhttps://github.com/WordPress/WordPress/commit/a2693fd8602e3263b5925b9d799ddd577202167d
- www.debian.orgDSA-4090https://www.debian.org/security/2018/dsa-4090
- lists.debian.org[debian-lts-announce] 20171104 [SECURITY] [DLA 1160-1] wordpress security updatehttps://lists.debian.org/debian-lts-announce/2017/11/msg00003.html
- www.securityfocus.com101638http://www.securityfocus.com/bid/101638
- wpvulndb.comhttps://wpvulndb.com/vulnerabilities/8941
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.8.3
- blog.ircmaxell.comhttps://blog.ircmaxell.com/2017/10/disclosure-wordpress-wpdb-sql-injection-technical.html
- wordpress.orghttps://wordpress.org/news/2017/10/wordpress-4-8-3-security-release/
07 Fixed in
Debian 12
- wordpress Fixed in 4.8.3+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.8.3+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.8.3+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- wordpress No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.