CVE-2017-15099
INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, and 9.5.x before 9.5.10 disclose table contents that the invoker lacks privilege to read. These exploits
02 Description
INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, and 9.5.x before 9.5.10 disclose table contents that the invoker lacks privilege to read. These exploits
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 6.32% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 93.3% of scored records. A rank, not a probability.
- NVD base score
- 6.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Low. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-11-22 18:00Z8 YR AGO
- Last updated
- 2024-09-16 16:43Z2 YR AGO
- Reserved
- 2017-10-08
- Assigning CNA
- redhat
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-200Exposure of Sensitive Information to an Unauthorized ActorClass
- Data version
- 5.1
- Document digest
- 4653c541597e787f45a09e2e45abb2370e1980a28eda081414c4dc2309db78a1
05 Affected products
06 References
- www.securityfocus.com101781http://www.securityfocus.com/bid/101781
- access.redhat.comRHSA-2018:2511https://access.redhat.com/errata/RHSA-2018:2511
- www.postgresql.orghttps://www.postgresql.org/support/security/
- www.securitytracker.com1039752http://www.securitytracker.com/id/1039752
- www.postgresql.orghttps://www.postgresql.org/about/news/1801/
- access.redhat.comRHSA-2018:2566https://access.redhat.com/errata/RHSA-2018:2566
- www.debian.orgDSA-4028https://www.debian.org/security/2017/dsa-4028
07 Fixed in
Arch Linux
- postgresql Fixed in 10.1-1
- postgresql-old-upgrade Fixed in 9.6.6-1
Source: Arch Linux Security Tracker, the Arch Linux security team. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- postgresql-9.5 Fixed in 9.5.10-0ubuntu0.16.04
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.