CVE-2017-14482
GNU Emacs before 25.3 allows remote attackers to execute arbitrary code via email with crafted "Content-Type: text/enriched" data containing an x-display XML element that specifies execution of shell
02 Description
GNU Emacs before 25.3 allows remote attackers to execute arbitrary code via email with crafted "Content-Type: text/enriched" data containing an x-display XML element that specifies execution of shell
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 4.00% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 90.1% of scored records. A rank, not a probability.
- NVD base score
- 8.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Important. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-09-14 16:00Z9 YR AGO
- Last updated
- 2024-08-05 19:27Z2 YR AGO
- Reserved
- 2017-09-14
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-20Improper Input ValidationClass
- Data version
- 5.1
- Document digest
- 0922d272ca96dc66cef7dc890ce05f532f1f677de4aa30ee0757e7dad0c4c596
05 Affected products
06 References
- www.debian.orgDSA-3975http://www.debian.org/security/2017/dsa-3975
- git.savannah.gnu.orghttps://git.savannah.gnu.org/cgit/emacs.git/commit/?h=emacs-25&id=9ad0fcc54442a9a01d41be19880250783426db70
- www.debian.orgDSA-3970https://www.debian.org/security/2017/dsa-3970
- security.gentoo.orgGLSA-201801-07https://security.gentoo.org/glsa/201801-07
- access.redhat.comRHSA-2017:2771https://access.redhat.com/errata/RHSA-2017:2771
- www.gnu.orghttps://www.gnu.org/software/emacs/index.html#Releases
- www.openwall.comhttp://www.openwall.com/lists/oss-security/2017/09/11/1
- debbugs.gnu.orghttps://debbugs.gnu.org/cgi/bugreport.cgi?bug=28350
07 Fixed in
Ubuntu 14.04 LTS
- emacs24 Fixed in 24.3+1-2ubuntu1.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- emacs24 Fixed in 24.5+1-6ubuntu1.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.