CVE-2017-12869
The multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to bypass authentication context restrictions and use an authentication source defined in config/authsources.php via
02 Description
The multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to bypass authentication context restrictions and use an authentication source defined in config/authsources.php via
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 2.36% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 83.5% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-09-01 13:00Z9 YR AGO
- Last updated
- 2024-08-05 18:51Z2 YR AGO
- Reserved
- 2017-08-15
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- CWE-20Improper Input ValidationClass
- Data version
- 5.1
- Document digest
- 4e9a965d65e5493404081c4c5404a830f83e5b5bcac9b07658279370d09eb3c3
05 Affected products
06 References
- simplesamlphp.orghttps://simplesamlphp.org/security/201704-02
- lists.debian.org[debian-lts-announce] 20171212 [SECURITY] [DLA 1205-1] simplesamlphp security updatehttps://lists.debian.org/debian-lts-announce/2017/12/msg00007.html
- www.debian.orgDSA-4127https://www.debian.org/security/2018/dsa-4127
07 Fixed in
Debian 12
- simplesamlphp Fixed in 1.14.15-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- simplesamlphp Fixed in 1.14.15-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu Pro 16.04 LTS
- simplesamlphp No fix yet
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.