CVE-2017-11628
In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, a stack-based buffer overflow in the zend_ini_do_op() function in Zend/zend_ini_parser.c could cause a denial of service or potentially
02 Description
In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, a stack-based buffer overflow in the zend_ini_do_op() function in Zend/zend_ini_parser.c could cause a denial of service or potentially
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 3.36% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 88.2% of scored records. A rank, not a probability.
- NVD base score
- 7.8 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-07-25 23:00Z9 YR AGO
- Last updated
- 2024-08-05 18:12Z2 YR AGO
- Reserved
- 2017-07-25
- Assigning CNA
- mitre
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- fe07746179dd1a864d188ae47cf9ba202916c3304ebc706c551f42bf7843aed6
05 Affected products
06 References
- git.php.nethttp://git.php.net/?p=php-src.git%3Ba=commit%3Bh=05255749139b3686c8a6a58ee01131ac0047465e
- access.redhat.comRHSA-2018:1296https://access.redhat.com/errata/RHSA-2018:1296
- security.netapp.comhttps://security.netapp.com/advisory/ntap-20180112-0001/
- git.php.nethttp://git.php.net/?p=php-src.git%3Ba=commit%3Bh=5f8380d33e648964d2d5140f329cf2d4c443033c
- www.debian.orgDSA-4081https://www.debian.org/security/2018/dsa-4081
- www.debian.orgDSA-4080https://www.debian.org/security/2018/dsa-4080
- bugs.php.nethttps://bugs.php.net/bug.php?id=74603
- www.securityfocus.com99489http://www.securityfocus.com/bid/99489
- security.gentoo.orgGLSA-201709-21https://security.gentoo.org/glsa/201709-21
07 Fixed in
Ubuntu 14.04 LTS
- php5 Fixed in 5.5.9+dfsg-1ubuntu4.22
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- php7.0 Fixed in 7.0.22-0ubuntu0.16.04.1
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.