CVE-2017-1001000
The register_routes function in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in the REST API in WordPress 4.7.x before 4.7.2 does not require an integer identifier, which allows
02 Description
The register_routes function in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in the REST API in WordPress 4.7.x before 4.7.2 does not require an integer identifier, which allows
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 84.93% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 99.7% of scored records. A rank, not a probability.
- NVD base score
- 7.5 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- No Red Hat rating. Red Hat rates the CVEs that affect its products.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-04-03 01:00Z9 YR AGO
- Last updated
- 2024-08-05 22:00Z2 YR AGO
- Reserved
- 2017-04-02
- Assigning CNA
- joshbressers
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- No CWE assigned
- Data version
- 5.1
- Document digest
- 0c19407e3d259288750f9d2b4b0791f58f9251957353310288e9606f30a3211f
05 Affected products
06 References
- codex.wordpress.orghttps://codex.wordpress.org/Version_4.7.2
- make.wordpress.orghttps://make.wordpress.org/core/2017/02/01/disclosure-of-additional-security-fix-in-wordpress-4-7-2/
- blogs.akamai.comhttps://blogs.akamai.com/2017/02/wordpress-web-api-vulnerability.html
- gist.github.comhttps://gist.github.com/leonjza/2244eb15510a0687ed93160c623762ab
- blog.sucuri.nethttps://blog.sucuri.net/2017/02/content-injection-vulnerability-wordpress-rest-api.html
- github.comhttps://github.com/WordPress/WordPress/commit/e357195ce303017d517aff944644a7a1232926f7
- wordpress.orghttps://wordpress.org/news/2017/01/wordpress-4-7-2-security-release/
- www.openwall.com[oss-security] 20170210 Re: Asking for a CVE id for the WordPress Privilege Escalation vulnerability (4.7/4.7.1)http://www.openwall.com/lists/oss-security/2017/02/10/16
- www.securitytracker.com1037731http://www.securitytracker.com/id/1037731
07 Fixed in
Debian 12
- wordpress Fixed in 4.7.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 13
- wordpress Fixed in 4.7.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
Debian 14
- wordpress Fixed in 4.7.2+dfsg-1
Source: Debian Security Tracker, the Debian security team. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.