CVE-2017-0898
Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting
02 Description
Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting
03 Exploitation and scoring
- Exploitation
- Not assessed. CISA has not published an exploitation assessment for this record, and it is not in the KEV catalog. That is an absence of assessment, not a finding of no risk.
- SSVC decision
- Not assessed by CISA
- EPSS probability
- 9.71% probability of exploitation activity in the next 30 days.
- EPSS percentile
- Equal to or higher than the score of 95.2% of scored records. A rank, not a probability.
- NVD base score
- 9.1 (CVSS v3.x), scored by the NVD independently of the CNA.
- NVD CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- NVD analysis status
- Modified. NVD last modified this record on 2026-06-17.
- Red Hat severity
- Moderate. Red Hat's rating for its own products, not a CVSS rating.
Exploit-prediction scores from FIRST. Independent scoring and analysis status from the NVD. Vendor severity from Red Hat. Exploitation assessment and catalog membership from CISA.
04 Metadata
- Published
- 2017-09-15 19:00Z9 YR AGO
- Last updated
- 2024-09-17 01:36Z2 YR AGO
- Reserved
- 2016-11-30
- Assigning CNA
- hackerone
- Record state
- PUBLISHED
- Severity
- Not rated by the issuing CNA
- CNA CVSS vector
- Not published by the issuing CNA
- Weaknesses
- Data version
- 5.1
- Document digest
- 212193822cba3f820a8a20ea4e05d313d320f247334eecfa60c19dd453a769f6
05 Affected products
06 References
- usn.ubuntu.comUSN-3685-1https://usn.ubuntu.com/3685-1/
- hackerone.comhttps://hackerone.com/reports/212241
- access.redhat.comRHSA-2018:0585https://access.redhat.com/errata/RHSA-2018:0585
- access.redhat.comRHSA-2018:0378https://access.redhat.com/errata/RHSA-2018:0378
- www.debian.orgDSA-4031https://www.debian.org/security/2017/dsa-4031
- www.securityfocus.com100862http://www.securityfocus.com/bid/100862
- www.securitytracker.com1039363http://www.securitytracker.com/id/1039363
- access.redhat.comRHSA-2017:3485https://access.redhat.com/errata/RHSA-2017:3485
- lists.debian.org[debian-lts-announce] 20180714 [SECURITY] [DLA 1421-1] ruby2.1 security updatehttps://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- access.redhat.comRHSA-2018:0583https://access.redhat.com/errata/RHSA-2018:0583
- github.comhttps://github.com/mruby/mruby/issues/3722
- www.ruby-lang.orghttps://www.ruby-lang.org/en/news/2017/09/14/sprintf-buffer-underrun-cve-2017-0898/
- security.gentoo.orgGLSA-201710-18https://security.gentoo.org/glsa/201710-18
07 Fixed in
Ubuntu 14.04 LTS
- ruby1.9.1 Fixed in 1.9.3.484-2ubuntu1.5
- ruby2.0 Fixed in 2.0.0.484-1ubuntu2.10
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
Ubuntu 16.04 LTS
- ruby2.3 Fixed in 2.3.1-2~16.04.10
Source: Ubuntu, Canonical Ltd. Licensed under CC BY-SA 4.0. Received through OSV.dev. Reformatted by exploit.cc.
A release or ecosystem missing from this list has no record here. It may be unaffected or not covered by the source. Source notices and licences.